VMware 9.0 incompatibile con Linux Kernel 3.5, come risolvere

VMware 9.0 incompatibile con Linux Kernel 3.5, come risolvere

L'ultima versione del software di virtualizzazione WMware (VMware Workstation 9.0) non è nata sotto una buona stella. Ci sono parecchi bug tra i quali uno piuttosto grave che ne impedisce il funzionamento. Mi riferisco alla clamorosa incompatibilità con il Linux Kernel 3.5: vmmon, uno dei moduli di VMware, blocca completamente il Kernel mandandolo in "Kernel Panic"!

Come usare VMware 9 con il kernel linux 3.5?

Fortunatamente esiste già una patch che si può trovare nel forum della community di VMware nella seguente discussione: VM's won't start on Linux host - kernel panic. Applicando la patch e ricompilando i moduli del kernel per VMware, il problema viene risolto, ma sinceramente spero che sia rilasciata una versione corretta al più presto.

VMware 9 ed ArchLinux

Spesso VMware ha dei problemini di compatibilità con le varie versioni del Kernel Linux, ma gli utenti della distribuzione ArchLinux hanno un asso nella manica: si tratta di un pacchetto disponibile su AUR che contiene una serie di patch correttive tra le quali troviamo anche quella per garantire la compatibilità tra VMware Workstation 9.0 ed il Linux Kernel 3.5. Scaricando il pacchetto vmware-patch ed attivando le patch, è infatti possibile compilare senza problemi i moduli di VMware per farlo funzionare anche con l'ultima release del kernel Linux.

Una versione con parecchi bug

Oltre a questo grave bug ne esistono molti altri segnalati nella sezione "problemi noti" che si può trovare nella pagina con le note di rilascio di WMware Workstation 9.0. Varie incompatibilità con particolari configurazioni e combinazioni di hardware e software che non fanno onore ad uno dei software di virtualizzazione più diffusi ed usati.

Complimenti per l'articolo, mi è stato molto utile.
Anche io spero che vmware rilasci un update almeno prima dell'uscita di ubuntu 12.10.
Un saluto

Dalla 9.0.1 hanno incluso la patch.

Invia nuovo commento
Il contenuto di questo campo è privato e non verrà mostrato pubblicamente.
Refresh Type the characters you see in this picture. Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.  Switch to audio verification.