Archlinux ed aggiornamento ad X.Org 1.6

Se, aggiornando Archlinux, i pacchetti di X.Org hanno interrotto l'operazione con questo messaggio:

errore: impossibile preparare l'operazione
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
xorg-server: /usr/lib/xorg/modules/extensions/libdri.so è già presente nel filesystem
xorg-server: /usr/lib/xorg/modules/libwfb.so è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Significa che il sistema sta aggiornando X.Org alla versione 1.6. Oltre alle numerose novità della nuova versione, gli sviluppatori di Archlinux hanno rifatto i pacchetti di installazione e ciò causa questo messaggio.

Non c'è nulla di cui preoccuparsi. Per risolvere il conflitto basta aggiornare il pacchetto xorg-server forzando la sovrascrittura dei file esistenti:

pacman -Sf xorg-server

Poi si può procedere tranquillamente con l'aggiornamento degli altri pacchetti.

Invia nuovo commento
Il contenuto di questo campo è privato e non verrà mostrato pubblicamente.
Refresh Type the characters you see in this picture. Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.  Switch to audio verification.